Перейти к содержимому
Александр

Art-Net гейт на базе Arduino

Рекомендуемые сообщения

cucie    0
6 часов назад, aleks сказал:

Что то ни фига у меня не получается ...

Если это возможно , расскажите пожалуйста подробнее , как создать соединение 

 

что именно не получается? связь между компом и езернет шилдом есть? 

лампочки около кабеля моргают? 

Поделиться сообщением


Ссылка на сообщение
aleks    0

Вот вот , не получается связать шилд с ПК , комп его не видит.

лампочки на разьеме молчат  , хотя на самой плате какая то жизнь происходит светодиоды периодически помигивают

Поделиться сообщением


Ссылка на сообщение
cucie    0
7 часов назад, aleks сказал:

... может мне шилд попался не рабочий ?

 

1. кабель. воткните заведомо рабочий.

2. езернет-адаптер компа. подключите его к заведомо рабочему устройству. роутеру, например. поменяйте комп на другой.

3. воткните артгейт в роутер, например.

даже если настройки люто корявые, у езернетшилда должны весело заморгать в момент подключения две лампочки снаружи.

20170314_003200.jpg

Поделиться сообщением


Ссылка на сообщение
aleks    0

спасибо за подсказку ! 

подключил к шилду  роутер , так и есть индикаторы на разьеме загорелись - желтый мигает зелены просто горит . на плате горят - RX ,  FULLD , 1OOM и мигает LINK

насколько я понимаю шилд рабочий .....

но какие произвести настройки компа я так и не накопал ....

Поделиться сообщением


Ссылка на сообщение
cucie    0
1 час назад, aleks сказал:

спасибо за подсказку ! 

подключил к шилду  роутер , так и есть индикаторы на разьеме загорелись - желтый мигает зелены просто горит . на плате горят - RX ,  FULLD , 1OOM и мигает LINK

насколько я понимаю шилд рабочий .....

но какие произвести настройки компа я так и не накопал ....

Если комп воткнуть в роутер вместо ардуины, линк есть?

У вас какая то беда с езернет адаптером у компа, кмк. Может отключен, может драйверов нет.

Можете прислать скриншотов настроек, посмотрим

Поделиться сообщением


Ссылка на сообщение
aleks    0

вот воткнул роутер в комп вместо ардуины , индикация подключения кабеля горит оранжевым

DSC01144.thumb.JPG.57ed16f09f484a2524602a8eba3eb773.JPG

сделал фото , потому что на роутере нет индикатора линк , то что светится это WAN

дальше ....

настройки адаптера ....58c7ce190edf5_.jpg.b80b751245a98d712737ebcf15516842.jpg58c7ce6ac3ab6_4.thumb.jpg.c3259f1d81626d659fafd886aaba17d7.jpg58c7cece67dcf_3.thumb.jpg.2c091f6ff2798dce33821c01d12c5242.jpg

Изменено пользователем aleks

Поделиться сообщением


Ссылка на сообщение
aleks    0

и еще одна непонятность...

попробовал я проверить интернет шилд скетчем DhcpAddressPrinter ... надеялся может IP адрес увижу ...

нифига  .....

во время загрузки шилд вместе с Мегой поморгают лампочками , вроде бы как положено 

после загрузки на разъеме и на плате лампочки мигают , а на мониторе порта ( я использовал версию 1.6.13 )

вот такую вот байду пишет58c7d49e84fc3_5.jpg.48443479bdbb9c163c78a3442311555c.jpg

Поделиться сообщением


Ссылка на сообщение
5 часов назад, aleks сказал:

и еще одна непонятность...

попробовал я проверить интернет шилд скетчем DhcpAddressPrinter ... надеялся может IP адрес увижу ...

нифига  .....

во время загрузки шилд вместе с Мегой поморгают лампочками , вроде бы как положено 

после загрузки на разъеме и на плате лампочки мигают , а на мониторе порта ( я использовал версию 1.6.13 )

вот такую вот байду пишет58c7d49e84fc3_5.jpg.48443479bdbb9c163c78a3442311555c.jpg

Парни, что вы все ищете себе проблем? Читайте внимательно. Какой DHCP? Это устройство изначально было создано со статическим IP адресом. Ни роутер ни какой-либо комп не может ему дать IP адрес. У гейта в прошивку ВБИТ СТАТИЧЕСКИЙ IP АДРЕС. И подайте наконец отдельно питание на DMX плату. Всей схеме банально не хватает питания, потому и не работает нифига. 

Поделиться сообщением


Ссылка на сообщение
cucie    0

если нет линка между роутером и компом, походу конец порту компа. 

попробуйте в любой другой комп воткнуть.

 

Изменено пользователем cucie

Поделиться сообщением


Ссылка на сообщение
cucie    0

если другого компа нет, подключайте по вафле.

для этого надо перенастроить роутер:

адрес 2.0.0.1,

маска сети 255.0.0.0,

dhcp включить, раздавать адреса 2.0.0.ххх

 

ардуину со всем барахлом втыкаете в роутер, компьютер по вафле подключается к тому же роутеру. настройки вафли - всё автоматом.

 

на картинке пример настройки моего роутера

Untitled.jpg

Поделиться сообщением


Ссылка на сообщение
aleks    0

попробую еще и так как вы предлагаете сделать

Поделиться сообщением


Ссылка на сообщение
aleks    0

Добрый день всем участникам этой темы (Art-Net Node)   

Сегодня , после небольшого перерыва и проветривания мозгов в саду продолжаю разбираться с УСТРОЙСТВОМ ,которое притерпело некоторые изменения

Так вот , во первых ; 

решил я запитать плату DMX от собственного стабилизатора , для этого отрезал дорожку 5v  , приколхозил ЛС L7805 на плату и взял питание с ножки - Vin    Сделал я это по двум причинам ; 1 - стабилизатор на Меге 1117 просто нереально нагревался ; 2 - в даташите на 75176  написано что питание должно быть мин 4.75в макс 5в , когда плата запитывалась от Меги 5в, просадка была аж 4,4в 

во вторых;

переключил пины как в коде Ардуины и на схеме DMX платы т.е 22 , 24 , 26 , и 28

в третьих ;

сегодня после "проветривания" наткнулся на эту тему -   http://forum.iobroker.net/viewtopic.php?t=1609   посмотрел на свой Шилд и офигел , такая же байта как описано , плаго под рукой материнка от старого компа которая иногда выручает детальками , заменил сборку 511 на 560

И вот хочу поделиться результатом всего лишь трех часов работы58ce997fca9ec_7.jpg.2986ce95d552ec205883ade2d0771171.jpg

в общем , все заработало !!!!

Теперь осталось проверить на приборах....

Отсюда вывод : все таки полезно делать проветривание мозгов 

И хочу поблагодарить всех Сочувствующих  соискателей и мастеров за участие , надеюсь кому то пригодится и мой отыт в создании устройства !

Поделиться сообщением


Ссылка на сообщение
aleks    0

Не откладывая в долгий ящик , проверил Устройство на PAR64 ( как чувствовал , что нужно оставить в машине ) ...

Все прекрасно работает !!!

В общем Китайцев нужно перепроверять ,,,,,

Поделиться сообщением


Ссылка на сообщение
designman    0
В 23.01.2017 в 01:51, far сказал:

А есть ли у кого прошивка, что б был web интерфейс и можно было параметры выбирать. На ebay полно девайсов в продаже. Собраны то же на arduino. Держал в руках, но не долго. Очень удобная штука. 

Вот пример: 

 

Вот что стоит внутри этого конвертера:

DSC04008.JPG

DSC04009.JPG

DSC04010.JPG

Вот что стоит внутри этого конвертера:

Изменено пользователем designman

Поделиться сообщением


Ссылка на сообщение
F1ma    0

Приветствую, на днях пришли китайские Мега 2560 R3 и Ethernet Shield W5100 R3. Соединил этот чудо бутерброд и попробовал залить скетч, в итоге вся эта кухня зависает, в проге горит статус Uploading to U/O Board, на шилде горит оранжевый индикатор, и так до бесконечности. Если шить отдельно мегу, то все ок. Может кто сталкивался с такой проблемой.... ?

Поделиться сообщением


Ссылка на сообщение

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас


×
Индекс цитирования